Excursion A03 Touch Panel issues with Windows 10 1511 Update

For those having issues with erratic touch panels on the Excursions starting with A03 Serials you can download the driver below to fix the issues. Use the following Instructions to update the Driver.

1. Download the driver and extract the zipped contents to a folder. You can place this anywhere you like just remember where you place it as you will need it later.

2. Go to Device manager and right click the KMDF Minddriver device under human interface devices and click uninstall. When the box pops up make sure the click the checkbox to delete the installled driver and press ok.

3. Go back to the folder where you extracted the driver. Right click the install.bat file and hit run as administrator. A box will pop up and press ok. When it says press any key to continue just hit the spacebar and the box should dissapear.

4. Check the touch function. It should be working and have no ghost clicks popping up.

Touch Panel Driver for Excursion A03 Windows 10-1511

7 people like this

 The link provided does not work.  Is there something I might be doing wrong or a better link for the driver?

 I get an error when I try to run the install.bat file as an admin.  Here's the MS-DOS screen of the interaction.

I brought the Vulcan XB tablet 8 days ago, and noticed the touch-pad problem. The support staff, April Rodriguez, mentioned that a new driver is available. So I followed the instruction and the link at the beginning of this thread. The new driver fixes the touch-pad problem. The important thing is to run the install.bat with administrator privilege.


There must be something that I am doing wrong then.  Even if I run the install as administrator, I get the error as shown in the Word DOCX that I added in my previous response.  Beyond that, I have not heard directly from Vulcan to see if my situation can be resolved.  I was on a text chat with April during a meeting trying to get it resolved with no success when my wifi signal was lost.  I have not heard from her since.  Even after I added some details to the ticket item that was opened for my issue.

If you are getting errors and the driver isnt installing please go to device manager and under input devices right click and remove the KDFMinddriver device. Make sure to check the box to delete the driver. Then re run the setup batch file again and it should work fine. 

After 30 minutes of fighting with the ghost touches, I finally got the driver deleted and the TP driver installed.  Installer said it worked.  But, the ghost touches returned.  I am not going to attempt further in trying to fix this.  I have lost all inclination or desire to get this tablet fixed.  In addition, I am well beyond the warranty time period.
Well Jason, I too had a lot of problems but decided to send it to them.  The only disappointing thing is that I had to PAY to send it to them....which means I actually was paying more for a tablet that really isnt worth as much as I have invested in it.  To add to that, there is only ONE person to answer phone calls and answer emails.  There is NO supervisor, per what they tell me, and so I have NO ONE to talk to over the ONE person in customer service.  This tells me that this company isnt worth much and I would NEVER recommend it to ANYONE at this point.  Lets see if my new device has any troubles